Buildroot: HDF5 configure error when using --enable-parallel with MPICH

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Buildroot: HDF5 configure error when using --enable-parallel with MPICH

Mehdi.Trabelsi.Ajili-EXT
Hello,

I am trying to compile HDF5 for embedded ARM using buildroot and I found this patch
https://patchwork.ozlabs.org/patch/425217/ .

I am actually new to buildroot and cross compiling and had many difficulties with configuring HDF5, then the patch helped me to set all the AC_TRY_RUN variables and everything worked perfectly.

To extend my work, I needed to install the mpich library to run HDF5 in parallel mode. MPICH was installed correctly, then I just added the --enable-parallel flag to my HDF5 configuration and then a new error messages occured at the configuration:

checking whether a simple MPI-IO program can be linked... no
configure: error: unable to link a simple MPI-IO application

I wanted to deactivate this test but I couldn't find which variable to set.
This is the part of code responsible for the test in configure.ac:

 ## Check that we can link a simple MPI and MPI-IO application
 AC_MSG_CHECKING([whether a simple MPI-IO program can be linked])
 AC_TRY_LINK(, [MPI_Init(); MPI_File_open();],
             [AC_MSG_RESULT([yes])],
             [AC_MSG_RESULT([no])
             AC_MSG_ERROR([unable to link a simple MPI-IO application])])

I couldn't figure out how to influence the result of this test.


May be someone has an idea how to install HDF5 with --enable-parallel using buildroot?

Thanks,

Mehdi
_______________________________________________
Hdf-forum is for HDF software users discussion.
[hidden email]
http://lists.hdfgroup.org/mailman/listinfo/hdf-forum_lists.hdfgroup.org
Twitter: https://twitter.com/hdf5