[hdf-forum] HDF5 Attribute issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[hdf-forum] HDF5 Attribute issue

Nikhil Laghave
Hello,

It looks like h5awrite_f does not work when there are more than 1 attributes.

I am writing attribute for one of the datasets and this contains some integers
and some reals. So I have created a compound dataset for this purpose.

Now as mentioned in the tutorial, we need to write one datatype at a time even
if we have a compound dataset with different datatypes. When I do these write
operations, only the first write actually writes to file. The rest of the
function calls do not write anything.

I tried changing the order to verify this and this is indeed what happens. Only
the first call works.

Can anyone tell me a way to overcome this ?

Regards,
Nikhil




----------------------------------------------------------------------
This mailing list is for HDF software users discussion.
To subscribe to this list, send a message to hdf-forum-subscribe at hdfgroup.org.
To unsubscribe, send a message to hdf-forum-unsubscribe at hdfgroup.org.




Reply | Threaded
Open this post in threaded view
|

[hdf-forum] HDF5 Attribute issue

Elena Pourmal
Hi Nikhil,

Could you please send me a short Fortran program that illustrates the  
problem?

Which version of the HDF5 Library  are you using?

Thank you!

Elena
On Sep 22, 2008, at 6:23 PM, Nikhil Laghave wrote:

> Hello,
>
> It looks like h5awrite_f does not work when there are more than 1  
> attributes.
>
> I am writing attribute for one of the datasets and this contains  
> some integers
> and some reals. So I have created a compound dataset for this purpose.
>
> Now as mentioned in the tutorial, we need to write one datatype at a  
> time even
> if we have a compound dataset with different datatypes. When I do  
> these write
> operations, only the first write actually writes to file. The rest  
> of the
> function calls do not write anything.
>
> I tried changing the order to verify this and this is indeed what  
> happens. Only
> the first call works.
>
> Can anyone tell me a way to overcome this ?
>
> Regards,
> Nikhil
>
>
>
>
> ----------------------------------------------------------------------
> This mailing list is for HDF software users discussion.
> To subscribe to this list, send a message to hdf-forum-subscribe at hdfgroup.org
> .
> To unsubscribe, send a message to hdf-forum-unsubscribe at hdfgroup.org.
>
>


----------------------------------------------------------------------
This mailing list is for HDF software users discussion.
To subscribe to this list, send a message to hdf-forum-subscribe at hdfgroup.org.
To unsubscribe, send a message to hdf-forum-unsubscribe at hdfgroup.org.